Rain Sensor Question - Buick Envision Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 05-13-2019, 09:17 AM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 1
Rain Sensor Question

Can someone tell me how the rain sensor works? The sensor on our 2018 Envision seems to be erratic. Most of the time it works fine, but occasionally it won't work at all while at other times it will run continuously on high speed with little or no rain on the windshield. I'm an electrical engineer, so technical descriptions are fine. Thanks in advance.
robinson725 is offline  
post #2 of 4 (permalink) Old 05-13-2019, 08:03 PM
Junior Member
 
Join Date: May 2019
Posts: 6
I don't have the automatic wipers on my Envision, but I did have them on my SRX.

The switch on the stalk controls the sensitivity. The graduated control on the stalk that would normally control the delay on a standard model is the sensitivity control for the autowipe. If you have the sensitivity dialed all the way up it will wipe the windshield more often and with less rain on it.

Did that make sense?!?
Trilo_G is offline  
post #3 of 4 (permalink) Old 05-23-2019, 11:43 PM
SS1
Junior Member
 
Join Date: Aug 2018
Location: CT
Posts: 12
Quote:
Originally Posted by robinson725 View Post
Can someone tell me how the rain sensor works? The sensor on our 2018 Envision seems to be erratic. Most of the time it works fine, but occasionally it won't work at all while at other times it will run continuously on high speed with little or no rain on the windshield. I'm an electrical engineer, so technical descriptions are fine. Thanks in advance.
I rarely have this issue. I also own a 2018 and I have 19,000 on my car after 13 months. Sometimes it will run to fast for the amount of rainfall. When this happens, I turn it off, wait 5 seconds, and turn it back on. It resets and works correctly. I believe the sensor just gets confused and senses more rain when there is not that much coming down (it particularly has problems some times slowing down when the rain slows down). A reset gets it going correctly again.

I don't know how much it happens to you. I would say this has happened maybe three or four times in the past year of ownership.
SS1 is offline  
 
post #4 of 4 (permalink) Old 06-21-2019, 10:13 AM
Member
 
Join Date: Jul 2018
Location: Northern New Jersey
Posts: 57
Garage
Hi, I was not using the rain sense wipers until yesterday. At sometimes they are erratic but for the bulk of the driving 30 miles they were pretty on spot. I attribute it to the sensor most likely in front of the rear view mirror on the window. I assume it is the sensor as there are times when the collision alert (unrelated) comes on from reflections, the sun or some other oddity that triggers it. Which if I am correct was pointed out in the Buick manual.
ATLANTICWAVE1000 is offline  
Reply




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome