Buick Envision Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
10 Posts
I personally haven't seen this but if the message is telling you to service your instrument cluster, my guess would be to check and see if any of the dash warning lights are not illuminating when you start the vehicle. They all light up for a moment, at this point in the start up procedure, but it's kind of hard to check them all.
 

·
Registered
Joined
·
1 Posts
I’m getting the same warning pop up and more frequently too. Took it into dealership where I purchased it new a month ago. They said no codes popped up but will have to replace the whole instrument cluster, which is on back order with no eta. They said I could be waiting months for a replacement. I’m left still confused why this happened, what it means and what could happen if I didn’t get the replacement. Dealership didn’t seem to want to explain a single thing about it. Would like to find answers as it’s a brand new car!
 

·
Registered
Joined
·
1 Posts
Bought 2022 Envision 12/29/2021 with 2,100 miles on it (loaner at dealership). Only a little over 6,100 miles on it now. Between pandemic and surgery it hasn’t been driven much. My “Service Instrument Cluster” warning popped up a week to 10 days ago. Tried to go to Info but had to dismiss pop up but no errors/issues in Info. Took to dealership and no errors or duplication of problem. Then error on dashboard 4 times in span of 22 miles 2 days ago. Took pics at each mile of pop up. Took to dealership with last one still on dashboard but appt was set for next day. Left all day and now replacing Instrument Cluster Module which has been ordered. No explanation. Also back auto lift gate hard to open with foot and when does will not close the same way. Replacing sensor which is on order too. I have never filled up my tires with air as much as this car. According to dealership no leaks of tires or stems. Something off and after dealing with what I went through to get this car, this is very disconcerting to hear of others having similar issues. I put cluster issue on update on 11/4-11/5 and then time change on 11/6 (when I had issue getting clock to change in car automatically) but dealership says no. Seems like all issues have started around this time frame. I am no computer whiz by any stretch of the imagination but now I truly believe it is a software issue. All these issues around same time frame seems too much to be coincidence.
 

·
Registered
Joined
·
4 Posts
Bought 2022 Envision 12/29/2021 with 2,100 miles on it (loaner at dealership). Only a little over 6,100 miles on it now. Between pandemic and surgery it hasn’t been driven much. My “Service Instrument Cluster” warning popped up a week to 10 days ago. Tried to go to Info but had to dismiss pop up but no errors/issues in Info. Took to dealership and no errors or duplication of problem. Then error on dashboard 4 times in span of 22 miles 2 days ago. Took pics at each mile of pop up. Took to dealership with last one still on dashboard but appt was set for next day. Left all day and now replacing Instrument Cluster Module which has been ordered. No explanation. Also back auto lift gate hard to open with foot and when does will not close the same way. Replacing sensor which is on order too. I have never filled up my tires with air as much as this car. According to dealership no leaks of tires or stems. Something off and after dealing with what I went through to get this car, this is very disconcerting to hear of others having similar issues. I put cluster issue on update on 11/4-11/5 and then time change on 11/6 (when I had issue getting clock to change in car automatically) but dealership says no. Seems like all issues have started around this time frame. I am no computer whiz by any stretch of the imagination but now I truly believe it is a software issue. All these issues around same time frame seems too much to be coincidence.
I’m also getting random alerts indicating ‘Service Instrument Cluster” which started around November 4 on my 2022 Envision Avenir. Vehicle is barely six months old. About 10500 km. I think that it might be tied to a software update that came in for my Avenir on November 3 – when I “successfully” did the update. Also had a dealer appointment on November 2 for tire swap and reset of sensors, but unlikely that this is relevant. Took the vehicle to dealer yesterday November 16 to check the alert. Dealer indicating that Instrument Cluster needs to be replaced – after 20 minute look (after keeping me waiting for 2 hours, of course). I’m uncomfortable starting to change out parts, especially since they did not want to offer any explanation or any detail, as another indicated.
 

·
Registered
Joined
·
2 Posts
As several other people have posted, I too am getting the "Service Instrument Cluster" message and my dealer also said they've never seen this problem. Isn't it strange that with so many of us having this same problem that GM doesn't have a solution?
 

·
Registered
Joined
·
40 Posts
Keep in mind that the Envision is manufactured in China with about 90% of the parts being Chinese made.

It does not surprise me that there are issues that an American tech has not seen, especially with the chip shortage, who knows what has been omitted or substituted.
 

·
Registered
Joined
·
4 Posts
I heard from my dealer this morning that GM has developed a software fix for this "Service Instrument Cluster" issue. I have an appointment to get it done. You may want to contact your dealer if you don't hear from them soon.
 

·
Registered
Joined
·
2 Posts
I heard from my dealer this morning that GM has developed a software fix for this "Service Instrument Cluster" issue. I have an appointment to get it done. You may want to contact your dealer if you don't hear from them soon.
Th
I heard from my dealer this morning that GM has developed a software fix for this "Service Instrument Cluster" issue. I have an appointment to get it done. You may want to contact your dealer if you don't hear from them soon.
Thanks for informa, I have a meeting with Dealer this week will ask them about fix, is there a web site GM which deals with this situation
 

·
Registered
Joined
·
2 Posts
I heard from my dealer this morning that GM has developed a software fix for this "Service Instrument Cluster" issue. I have an appointment to get it done. You may want to contact your dealer if you don't hear from them soon.
We called our dealer today, same issue, appt next week, car has 2,600 mi on it. ( 2022 Envision Avenir ) A little disturbing and we are still waiting for a chip for the heated seats.
 

·
Registered
Joined
·
4 Posts
Took my Envision Avenir in today for dealer to deal with the "service instrument cluster" alert issue. Technician's note said "...not replacing cluster due to new bulletin 22-na-237, following bulletin programmed instrument cluster...". Hope this deals with the issue. Hope this information helps you deal with yours.
 

·
Registered
Joined
·
2 Posts
I took my 2022 Enision in today as well for the "service instrument cluster". They've told me they fixed it with an update. Have not received my car back yet, all the sudden when it was ready for pickup I got a call back that the windshield washer fluid tank was leaking water as fast as they could put it in. Interesting:unsure:
 
1 - 18 of 18 Posts
Top