Buick Envision Forum banner
21 - 40 of 43 Posts

· Registered
Joined
·
6 Posts
I am back after posting on 11/16/22. Took 2022 Envision in to dealership yesterday, 11/5/22, 8AM for new Instrument Cluster module and rear hatch foot sensor to be installed. These were ordered on 11/16/22. Car kept all day and at 5PM got call that they “were still having issues and would have to keep it”. This AM went to pick up rental car (which was not ready because dealership did not notify Hertz) but finally got rental and started my day. Three hours later my car was ready. I finished my appointments and went to pick up my car. Ran a few errands and came home. It was parked in my garage until I went to pick up dinner. As I put car into drive to leave the restaurant that damn “Service Instrument Cluster” warning popped up again on the dashboard. Took another picture. Car had been driven 9 miles. I just about blew a gasket. Called Service Department and spoke with my rep who seemed surprised but asked that I bring it in again tomorrow. They will get me an other rental car. I am sure this will be a multi day ordeal. I have put off a couple of weekend trips and with the holidays approaching I am just leery of dashboard warnings about a computer module that runs the car. Being older I do not want to get stranded somewhere. As I mentioned previously I believe this is a software issue and as someone posted in the last few days there is an update supposedly to correct this problem. Well, gentlemen tomorrow AM I am going to have a good old fashion come to Jesus meeting and show them this forum and if I have to also have a hissy fit, I will. For all of us to have started this issue the first weekend in November there has to be a logical and accessible “fix” with software. I do not know where all of you are located but if you see a mushroom cloud from the direction of NC, you will know it is me.
That’s interesting, I’m taking my Buick in tomorrow for the same reason, when I made the appointment for repair and mentioned the fix is a software upgrade, I got a look from the guy
like who is this, I’m expecting a the same treatment you received, fixed but not fixed, and on top of it all, they just say bring it back and don’t say why it’s not fixed, I’m not surprised, ill post after I get my Buick back
 

· Registered
Joined
·
8 Posts
Remember to ask your dealer to look for the new GM bulletin #22-na-237. When I got my repair done at the dealer on December 2 the Technician wrote the following: "not replacing cluster due to new bulletin 22-na-237; following bulletin programmed instrument cluster".
 

· Registered
Joined
·
8 Posts
That’s interesting, I’m taking my Buick in tomorrow for the same reason, when I made the appointment for repair and mentioned the fix is a software upgrade, I got a look from the guy
like who is this, I’m expecting a the same treatment you received, fixed but not fixed, and on top of it all, they just say bring it back and don’t say why it’s not fixed, I’m not surprised, ill post after I get my Buick back
Remember to ask your dealer to look for the new GM bulletin #22-na-237. When I got my repair done at the dealer on December 2 the Technician wrote the following: "not replacing cluster due to new bulletin 22-na-237; following bulletin programmed instrument cluster".
 

· Registered
Joined
·
6 Posts
Remember to ask your dealer to look for the new GM bulletin #22-na-237. When I got my repair done at the dealer on December 2 the Technician wrote the following: "not replacing cluster due to new bulletin 22-na-237; following bulletin programmed instrument cluster".
Another interesting note , I took the car into the dealership for fix , wanted to give him copy of the bulletin, wouldn’t accept just said we will check it out , hope so , will wait for there call
 

· Registered
Joined
·
6 Posts
Another interesting note , I took the car into the dealership for fix , wanted to give him copy of the bulletin, wouldn’t accept just said we will check it out , hope so , will wait for there call
Picked up the car today, seemed to be corrected, happy so far, no charge on warranty work and the work invoice does indicate the software fix with the same numbers listed in post,
Hope it works for you
 

· Registered
Joined
·
8 Posts
Glad to know the Service Bulletin is working for everyone. I just called about my car which has been at the dealership for another 1 1/2 days. Rep said car was just finished but that the Manager is going to take it out and put some miles on it to see if everything is ok. No other explanation. When I asked if the Service Bulletin I shared with them yesterday AM was any help the reply was “Oh my yes! When the Tech had your car the other day this Bulletin wasn’t even out yet since it was just released yesterday!” Oh come on. I did not fall off the turnip truck yesterday. Bob above said he found out about it 11/28 and had it installed 12/2. Do not mess with this Southern woman. I truly detest liars. This is the second time at this dealership - once in Sales and now in the Service Department - that I have caught them in lies. I have their number which right now is batting a big fat ZERO. I have their rental car, have appointments this afternoon and probably will not pick up my car until tomorrow AM. (And by the way I was much nicer than I should have been yesterday. I decided it was too close to the holidays for people to get hurt.) Seriously though, I am looking forward to no further issues.
 

· Registered
Joined
·
8 Posts
Well gentlemen here it is 12/19/22 and my car is completely dead. No lights. No keyless entry. No remote start. Even my husband’s key fob will not work. The car is in my garage and after a trip to the dealership and back home, Roadside Assistance is on their way to tow it to dealership. The car was last driven on Friday, 12/16. I even got the Manuel out and and found if you press lock and unlock buttons on the key fob for 3 seconds it should unlock the fob but nothing. The whole car is just shut off. So now the mushroom cloud will probably be on your horizons . This was exactly my greatest fear and I even voiced it to the Service Department about this Service Cluster mess shutting the car completely down and stranding me somewhere. I do hope all your “updates” have fixed your problems. Ugh!!!
 

· Registered
Joined
·
6 Posts
Well gentlemen here it is 12/19/22 and my car is completely dead. No lights. No keyless entry. No remote start. Even my husband’s key fob will not work. The car is in my garage and after a trip to the dealership and back home, Roadside Assistance is on their way to tow it to dealership. The car was last driven on Friday, 12/16. I even got the Manuel out and and found if you press lock and unlock buttons on the key fob for 3 seconds it should unlock the fob but nothing. The whole car is just shut off. So now the mushroom cloud will probably be on your horizons . This was exactly my greatest fear and I even voiced it to the Service Department about this Service Cluster mess shutting the car completely down and stranding me somewhere. I do hope all your “updates” have fixed your problems. Ugh!!!
Sorry to hear, but yes so far after update we have had no issues, hope for the best
 

· Registered
Joined
·
8 Posts
Update from earlier:
Dealership had me call Roadside Assistance who got here and tow truck guy says battery is dead. Tried to jump but did not work. Since backed into garage he says he could not tow out due to angles (??? Seriously???) and was ordered to leave by his office. I asked him to stay as I called dealership who sent out Service Manager AND Service Rep. Dealership 4 miles away. But tow would not stay. They passed each other 100’ feet from my house. Dealership had Power Box that got car started but more service issues were popping up on dashboard. They took the car to the dealership and we will see. What a nightmare! (Service Rep mentioned something about car connecting to house WiFi for an update and then never shutting off which may have drained the battery. Apparently they have seen this before.) OMG! Again Seriously? So be aware I guess. I’ll advise on what seemed to be the “problem”.
 

· Registered
Joined
·
8 Posts
Update from earlier:
Dealership had me call Roadside Assistance who got here and tow truck guy says battery is dead. Tried to jump but did not work. Since backed into garage he says he could not tow out due to angles (??? Seriously???) and was ordered to leave by his office. I asked him to stay as I called dealership who sent out Service Manager AND Service Rep. Dealership 4 miles away. But tow would not stay. They passed each other 100’ feet from my house. Dealership had Power Box that got car started but more service issues were popping up on dashboard. They took the car to the dealership and we will see. What a nightmare! (Service Rep mentioned something about car connecting to house WiFi for an update and then never shutting off which may have drained the battery. Apparently they have seen this before.) OMG! Again Seriously? So be aware I guess. I’ll advise on what seemed to be the “problem”.
This same exact thing just happened to mine this morning, it’s still in the garage, you are able to get into the car if needed to get stuff out with key inside of fob, I haven’t tried jump starting it yet, I will when I get home, please update when you here from the dealer.
 

· Registered
Joined
·
8 Posts
This same exact thing just happened to mine this morning, it’s still in the garage, you are able to get into the car if needed to get stuff out with key inside of fob, I haven’t tried jump starting it yet, I will when I get home, please update when you here from the dealer.
Update #1, car jump started right away, looks like the car was taking an update that got stuck Friday evening, when I started the car it was still trying, I took it to the dealer because there’s also a day running light recall.
 

· Registered
Joined
·
8 Posts
Observation and Update:
Funny how the update the first weekend of Nov started all the “Service Instrument Cluster” warnings and now another update on 12/16 is draining the battery because it will not finish. Seems some engineer needs some extra coding assistance. This is truly ridiculous.
My dealership called and said “the car is giving our Techs fits. The update will not shut off.” They were going to keep it and get in touch with global techs tomorrow. Seems another service bulletin is needed - after they write more code to fix what they did this last time.
I truly hope that every update doesn’t create new issues every time. Having this much technology in a car is starting to make me want my good old 1972 Chevrolet Monte Carlo or even my 2003 Toyota Highlander back that I traded in for this 2022 Buick Envision. (I did have several other cars in between them.) I pick up my rental car tomorrow AM. I’ll update again once I know more and would appreciate the same from others.
 

· Registered
Joined
·
8 Posts
Update #2, The dealer replaced my battery, it was defective, my Envision is a 2022 with 4994 miles on it. They said an update that’s fails to install (even with car sitting for 2.5 days) shouldn’t kill the battery because after 20 mins everything shuts down if update isn’t finished. There’s some day running light recall that they also updated when the car was there and pushed stuck update through, I just picked car up a few hours ago, if anything fails I will update.
 

· Registered
Joined
·
8 Posts
Picked mine up this afternoon also. Same as above - update stuck but fail safes to keep battery from discharging did not work. Did not replace my battery although now I may ask for it. So tired of this crap. Is next computer update going to create yet another issue?
 

· Registered
Joined
·
8 Posts
Very sorry to hear of your experiences (mappitts and Big E) and thanks very much for sharing. Please do continue to keep us updated. It may help us to deal with the issues if we encounter similar stuff (hopefully not).
 

· Registered
Joined
·
1 Posts
I am experienced the same thing this happen after a software update the night before, the next day my service instrument cluster light came on in my new 2022 Buick Envision Avenir. The trouble started 11/3/2022 when I was driving home. Stop in at the near dealership. They pulled it in the shop then came back out 30 min and said it was taken care. Next day the light came back on called the dealership and the got me in appointment for 11/7/2022 worked on it for hour. Then gave the vehicle back said the instrument cluster need to be replace and have to order one, however item is on back order. Haven’t drove the car since I have another vehicle, however when I did take it for a drive around town I notice the vehicle odometer miles increase faster. Now my car is displaying more mile than I actually drove. On 12/13/2022 dearlership called said that after data was sent over to GM there was software update they need to perform. Asked if I could bring the vehicle in on 12/23/2022 I explain the issue about the odometer miles and they didn’t respond. I’m glad this forum exists.
 

· Registered
Joined
·
8 Posts
Update #3, since they changed the battery in December 20th haven’t had any issues. I forgot to mention when they had the car they also installed the chip for our heated seats, my wife was telling me when the car wouldn’t start she wanted it gone and for us to get another car, I told her it was meant to be, you got your heated seats for winter.
 

· Registered
Joined
·
23 Posts
Wow Gang, sorry to hear of these issues, I'm a new member here, joined yesterday ( Jan 14th 23 ) as my wife and I are looking to buy a new 2023 Envision, but now with all we are reading, we may have to consider something else, crossover wise, a shame really as we test drove a new Envision last week, love the looks and interior but cannot have these issues hit us. Best of luck to you all
 

· Registered
Joined
·
37 Posts
Wow Gang, sorry to hear of these issues, I'm a new member here, joined yesterday ( Jan 14th 23 ) as my wife and I are looking to buy a new 2023 Envision, but now with all we are reading, we may have to consider something else, crossover wise, a shame really as we test drove a new Envision last week, love the looks and interior but cannot have these issues hit us. Best of luck to you all
Did the Envision you test drove, have the seat heat and steering wheel heat chips? Was there any problem?
 

· Registered
Joined
·
23 Posts
Did the Envision you test drove, have the seat heat and steering wheel heat chips? Was there any pro&blem?
Yes it was a 2023 Avenir, loaded, but the temps here in southern Utah were mild, so sorry, I did not try the heated seats or steering wheel, if fact until now I didn't know about the chip shortage affecting these Buicks. We hadn't test drove one until last week, we really liked the road feel, interior comfort, the technology is a bit to get used to, like the 10 in info screen and push button trans, but all in all a very nice crossover. And looking at the window sticker, it does indicate a $25 & $50 "credit" on the sticker, with a "later Retrofit".....how long that retrofit will take to have completed is anyone's guess.
 
21 - 40 of 43 Posts
Top