Buick Envision Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Boy, this car has had more problems than any other new car I've had and it doesn't even have 12K on it..Today I noticed the rear AC zone was blowing warm. Turned the temp down to "LO" and still blowing warm air. Tried auto and manual, same thing. Then tried turning the temp up to "HI" to heat and it just quit altogether..What next..Anyone else have this issue? Front AC works fine. I wonder if it has it's own evaporator like rear AC on vans or if this would just be an air switching problem from the front to the back..

Cheers,

John
 

·
Registered
Joined
·
257 Posts
Only one condenser up front condenser. Sounds like the rear mixer is not working properly.

I believe you go in tomorrow but I'd try pulling the negative battery cable for 30minutes.
 

·
Registered
Joined
·
6 Posts
Yea. I had to take mine in the shop to get this fixed. As they were working on the rear ac they were kneeling on my driver and passenger seats. The technician must’ve had dirty/oily clothes as my seats then were stained. The passenger seat was horrible and and the driver seat needed to be cleaned. They replaced the passenger seat and the driver seat wasn’t much better. Service manager said that my driver seat was just from regular wear and tear. 🙄. Right. A whole lot of wear with 6000 miles. Too bad as I really want to like the car. It not impressed with GM with owning the problems. This is my first new car purchase. Should’ve bought the Acura 😕
 
1 - 5 of 5 Posts
Top