Buick Envision Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Anyone else have an issue with the car bucking? When I release brake sometimes she bucks like a manual when you come of the clutch and dont give enough gas. Just for a few seconds.
 

·
Registered
Joined
·
10 Posts
My Envision has had a number of tranny issues one resulting in the replacement of the shift control module while travelling in Florida. Before the module was replaced I had an intermittent problem with the car surging while cruising like the torque lockup was engaging and disengaging. The problem couldn't be recreated and wasn't found initially by my dealer. I had a problem with the unit not going into park a couple of times. In Florida, I then lost all drive at an intersection with the engine light coming on and the vehicle stating I wasn't meeting shift parameters... This resulted in a tow to the dealer and 13 days in the shop for an electrical issue and tranny module replacement. Once the new module was in, the surging problem disappeared.

Back in Canada, I now seem to have the problem you have. On startup, then in reverse, the vehicle will go into gear for a moment, then drop out of gear then back in/out several times backing out of the driveway. When I place it in forward the vehicle will move right away but the first few shifts over a block are very jerky until things warm up then it is normal. My feeling is that the tranny is low on oil but I can't check it (no dipstick). I think it wasn't properly filled when the repair took place in Florida and with the cold weather here, especially in the morning, I end up with this problem. When the mornings are very warm, it doesn't happen. The car is scheduled to be checked in a few days. I'll let you know what's found.
 
1 - 4 of 4 Posts
Top