Buick Envision Forum banner

41 - 60 of 63 Posts

·
Registered
Joined
·
22 Posts
jonjon-
No, I don't plan to address the wobble, since it hasn't seemed to get any worse, appears to be a complicated fix, and I don't want another hassle with local dealer service mechanics. Mine is a lease car, and even if it weren't, I would already be thinking trade-in, rather than more repair hassles. But that's just me.
You mention a complicated fix, have you information on what the issue is?
 

·
Registered
Joined
·
49 Posts
Discussion Starter #42
jonjon-
I have no official information, only assuming that the fix would be similar to your post on 02-26-2018, which alluded to fix for similar problem with Chevy Malibu. If you find the fix is otherwise, please share with us.
 

·
Registered
Joined
·
18 Posts
Hello!
So as it turns out my rear A/C stopped working and blew only hot air. I have a Premium II AWD fully loaded. the part took 6 weeks to come in and my dash also had to be ripped apart despite the rear A/C being affected- my issue was the exact same part as what you required. I am very worried about rattles and dials not turning, the fix just happened this week so I will have to be observant to any extra sounds. I also have to re-set all my presets.
 

·
Registered
Joined
·
1 Posts
We had the same issue and it was addressed at the dealership. A wire harness was not correctly connected which effectively disabled the rear control system. Works well now!
 

·
Registered
Joined
·
4 Posts
Here is my car after two weeks of being at the dealership. I am just sick. My car is gutted. I don’t want this car back after hearing others issues. This is a GM problem. I am going to ck out the Lemon Law. I am in Indiana. Anyone gotten a new vehicle out of this mess.
Mine is one year old.
 

Attachments

·
Registered
Joined
·
4 Posts
Picked up Envision on August 10. A mile down the road, hot air blowing on passenger side only. Took back to dealership. They drove several times and said working fine, needed to cycle through. Picked up again later that day, started blowing hot air on the passenger side before I even got two miles away. Needless to say sitting at dealership over the weekend. Have a nice loaner. More Buick issue than dealership issue. I will update...
 

·
Registered
Joined
·
22 Posts
I like the new styling of the Terrain loaner. It's a nice size, and the Terrain Denali would be even nicer. Our old 2010 Terrain never gave any trouble whatsoever. Would definitely buy another Terrain.
Did your Terrain have the same 2.0 turbo? Did you find it to have a lot more power than the Buick?
 

·
Registered
Joined
·
22 Posts
Here is my car after two weeks of being at the dealership. I am just sick. My car is gutted. I don’t want this car back after hearing others issues. This is a GM problem. I am going to ck out the Lemon Law. I am in Indiana. Anyone gotten a new vehicle out of this mess.
Mine is one year old.
OMG you have got to be kidding..That much tear down for the rear AC?? UGH! Mine goes in next week for the repair!!
 

·
Registered
Joined
·
49 Posts
Discussion Starter #49 (Edited)
jonjon- No, Terrain did not have 2.0 turbo. So no comparison there. I sympathize with all of you who have the A/C problems, and all the other problems with Envision, several of which have, unfortunately, plagued me as well. The most trouble I have ever had with any new car ever, going back to the 1960's, and for sure the first and last Buick for me.
 

·
Registered
Joined
·
22 Posts
We took our car in two weeks ago for the wobble in the front end, the rear AC not working and a loss in performance.
They had the car for a week and put us in a brand spanking new GMC Terrain (2019) that had the 2.0 turbo, just like the Envision.

They called and told us to come and get the car, that they have ordered parts and they should be in around the 20th which is this week. When we got there, the service advisor told me that they ordered a rear AC unit, and an axle for the wobble. I asked her about the loss in performance. I told her that the GMC, which has the exact same engine has about twice as much power. She said her tech said "not the same animal" So given the GMC had the nine speed transmission, I thought I would look deeper. First I checked the specs. The engine in the two are exactly the same output specs. Then I looked up the 0-60 specs and they are almost the same.

Buick 0-60=7.0 seconds (motor trend)
GMC 6-8 to "mid 7s" couldn't find exact numbers but dang close. The GMC also had this funky "push button" transmission that I hated. P and R you pull out, like how you lift your power window button to raise the window. Push button for P and N. The nine speed tranny was nice and smooth. Wish ours had that. Why did I hate the push buttons? You can't shift by feel. It looked really cool, until I had to jockey the car out of a tight spot. With a gear shift, you can switch back and forth without looking. You can't with these bush buttons. You have to keep looking down at the dash to change gears.

So now we see what happens when I take it back later this week..Will post later.
 

·
Registered
Joined
·
257 Posts
The 2019 Envision gets 9-speed and torque goes from 260 to 295 lb-ft of torque. I have more than that now with a ECU tune and seldom get the wobble.
 

·
Registered
Joined
·
51 Posts
I said I wasn't going to do it with this vehicle, but the tuning bug has bitten me. I know firsthand, with my Lincoln, what tuning can do for turbo vehicles.

I guess I need to start searching tuning on the forums.
 

·
Registered
Joined
·
4 Posts
Well got a call from dealership yesterday said the had to order a new temp control sensor. Should be here today. Asked if they would have to tear the car apart again and they said no. Still waiting. Anyone needing this repair look at my pics and make sure they have the parts to fix. Backorder of sealant kits seemed to be a problem. Who knows!!! I will post again when o see what the next problem to arise is. Scares me...
 

·
Registered
Joined
·
3 Posts
I had the same issue with my 2016 Envision II. Frogg's experience exactly mirrors mine - dealer diagnose, order part, part arrived, part damaged, part on back order, replacement part arrived, and 3 days to install. Round trip, looking at 2 months, and at least 3 rental cars courtesy of GM. I now have 3 working zones climate control, but suffered through July heat wave with heat from the rear console.
 

·
Registered
Joined
·
1 Posts
2017 Envision

Wow...8/24 and I just got my Envision back with the same rear A/C problem Will check out the vehicle later when I get home. Did want to advise about the handling issues mentioned in a few replies. I received messages from On-Star when my car was being worked on to have the dealer check the StabiliTrax stability control and service the Antilock Braking System. I mentioned this to my dealer and they indicated they serviced. I guess only time will tell. besides this issue, I love this car and the way it handles.
 

·
Registered
Joined
·
257 Posts
Waiting for my 2016 Pll with 17K miles to blow hot air on the rear vents. Even jumping the railroad tracks at work almost every day has not broken the sensor!
 

·
Registered
Joined
·
22 Posts
After three weeks in the shop, we got the car back. I think it was torn down to the bottom like the car above to fix the rear air. I didn't see it but my SA told me it was. I gave her the TSB on the axles, but I think GM had already told the guy what to order so not sure if they are the same as on that TSB. The rear AC works again and the wobble is GONE!!! Hallelujah!! The only thing they didn't address was the loss of power. My SA said the tech didn't see anything wrong with it. I told her that's because it's not his car. This car used to have screaming passing power. Hit it at 40-50 to pass someone and it would fly. Now, it feels like a non-turbo car..Don't know what to do about that. No engine light, no actual driveability issue (except one time, I took off hard from a light, going up a slight incline and the car felt like it was lagging, like something was pulling it from behind)
They also did the TSB on the differential but I was not having any rattling issue.

So that's where I am at. Fixed AC, Fixed the dang wobble but now have no idea why my car isn't as zippy as it used to be. I told my SA I suspected it had something to do with the turbo. Perhaps the wastegate not working properly. Never in recent times have I had a car that spent this much time in the shop.
 

·
Registered
Joined
·
4 Posts
Well I finally got my car back last week. The first time I go to use the navigation this week I have none!!!!’ Shows off road. Cked with On Star and Buick tech. They said needs to go back to dealer to recalibrate the navigation. Took to dealer on Monday. They called me yesterday and said problem is within radio or in the antenna and has nothing to do with the invasive repair of the previous pics I posted. Radio stuff is all contained and was just disconnected when they completely tore the dash apart to fix the rear air problem!! Really!! They tear my car apart because that is the only way that Buick can repair the rear air and then the first time I use the navigation I have none!! Navigation was fine when I took in for rear air problem. Antenna??? How can radio and XM work if it is the antenna?? So upset.. they are analyzing the problem... which means they probably don’t know what the **** is wrong.
 

·
Registered
Joined
·
51 Posts
That stinks. The navigation antenna is a different antenna from the radio and XM. It's possible when they tore things apart they did not put the navigation antenna back in the Dashboard.....Or did not put it incorrectly. I'm pretty sure that's where General Motors is still placing them. Towards the front of the car Passenger side underneath the Dashboard pad.....In any event, if it were me, before I took it back to the dealer, I would disconnect the positive battery cable for about 20 minutes and then reconnect it and see what happens with respect to the navigation.

Also I know the first time you tried it after the repair the navigation was not working, but could you say when the last time prior to that it was utilized? Just asking because I guess there is a possibility that the navigation stop working before you brought it in but you just didn't know about it. We probably only try to use the navigation may be once or twice a month, so if it wasn't working for me, I really wouldn't know when it stopped working.....
 
  • Like
Reactions: frogg
41 - 60 of 63 Posts
Top